Saturday, November 03, 2007

Family Tree Maker 2008 Bug - All data from people tab missing and how to find it.

I am going to start listing any of the bugs and fixes that I find for Family Tree Maker 2008 on the site. Maybe they will help someone that has lost data.

I have come across a bug in 17.0.0.438. While in the people tab, scrolling through the index, the program crashed. All I did was scroll up with the up arrow key, from one name to the next. The program closed completely and without any warning or error message.

When I try to restart FTM, this message appears: “The tree is already open or invalid file type [path]”. This message can be dismissed and the program will start. After the first failure, the typical Microsoft error message pops up. If you click the button to send the error report, the process will start but it will never actually send.

After restarting FTM, even after restarting the computer, the “open or invalid file” message appears each time. When inside the program, everything runs normally except that you cannot see anything on the people tab screen. The places, sources, etc. tabs work fine but the people tab data is not there. The funny thing is that you can press F2 and the index will come up, populated with data.

I then tried to export the file and open the exported file/packet, saved with a different name. This process worked fine and nothing appears to be lost, all of the tabs function properly. Even stranger is that once I exported the original file and then opened it and saved the package as a new file, the original file now works properly again, people tab and all.

3 comments:

Gladys said...

My Family Tree Builder is version 2.0.0.657
I had just started using the program which I thought was one of if not THE best-however, when I tried to login it could not find my internet connection - while I had my browser up and running
Then when I tried to print anything
it could not find my printer, when I just printed a text in Word.

I use Windows XP. I have tried to contact the company by email but there was no response for several tries.

I found a fax number which is located in Israel. Have not tried that - maybe something happened to the company?

regards Mike at gladysking556@gmail.com

Judy said...

I, too, am experiencing the exact same problem - any solution for getting the program to recognize my internet connection?

Anonymous said...

I'm so grateful for your post - the same thing just happened to me with FTM 2010. Contemplating the prospect of re-entering information for 20,000+ records, I was close to tears when some desperate googling found this website. Your solution works. (I won't dwell on the fact that an identified problem with FTM 2008 is still happening with FTM 2010 because doing so would only lead me into an unseemly rant.)

Virginia hasn't entered my area of research - as far as I'm aware - but stumbling onto this website in a moment of desperation was a blessing for which I'm very grateful. Thank you again.

Joan (in Toronto, Canada)